Vue-Router升级导致的Uncaught (in promise)问题(亲测有效)

在升级了Vue-Router版本到到3.1.0及以上之后,页面在跳转路由控制台会报Uncaught (in promise)的问题 这是什么原因呢?看vue-router的版本更新日志V3.1.0版本里面新增功能:push和replace方法会返回一个promise, 你可能在控制台看到未捕获的异常
阅读全文

新版phpStudy2018,支持自定义php7.3.4版本

新版phpStudy2018,支持自定义php7.3.4版本 首先到win版php官网下载 ,想要自定义的php版本,我这里下载的php7.3.4,目录重命名,保留版本号及nts ,如下图,复制到phpStudy安装目录的php文件夹即可。由于我使用的phpstudy2018版本,所以把php-7.3.4-nts里面所有的文件覆盖php-7.2.1-nt不然phpstudy启动软件上看不到自定义的php7.3.4,选择php7.2.1-nts,然后打印输出 phpinfo()
阅读全文

phpStudy环境下安装配置SSL证书,实现加密访问(Https)

一、何为SSL证书?SSL证书是什么?百度百科是这么解释的:SSL证书是数字证书的一种,类似于驾驶证、护照和营业执照的电子副本。因为配置在服务器上,也称为SSL服务器证书。SSL 证书就是遵守 SSL协议,由受信任的数字证书颁发机构CA,在验证服务器身份后颁发,具有服务器身份验证和数据传输加密功能。
阅读全文

川公网安备 51010702002018号